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About this demo

This demonstration version of Adrenaline Numbers & Charts 1.0.2 is functionally equivalent 
to the shipping version of Adrenaline Numbers & Charts 1.0.2. This version has an expiration
date of November 1st, 1997. Printing and saving are also disabled. 

Installation

To install Adrenaline Numbers & Charts on your system, double-click on the application 
labelled "Install Numbers & Charts 1.0.2". This will launch the installer. You have the choice 
of installing the complete Numbers & Charts 1.0.2 package (which includes the software, 
tutorial, some sample 3D objects, textures and more) or of doing a custom install.

You must be running System 7.5.3 or later to install Numbers & Charts 1.0.2 on your system.
Otherwise, the installer program will notify that they need to be installed and then quit. The 
Apple software folder on the CD-ROM contains updaters allowing you to upgrade Systems 
7.5.x up to version 7.5.5 (the latest version of the system software before MacOS 7.6)

You MUST have Apple's System Software 7.5.3 or later, OpenDoc 1.1 or later, QuickDraw 3D 
1.5.1 or later, AND QuickTime 2.1 or later installed on your system for Adrenaline Numbers &
Charts to install. Otherwise, the installer program will notify you that they need to be 
installed, and then quit. Once you have installed the required software, please re-launch the 
Numbers & Charts installer.



Installation on non-English systems

If you are running a non-English version of the system software, you must do a manual 
install of the product. In the installer application, click on the pop-menu labelled "Easy 
Install" and select the "Custom Install" option. In the list of options, click the checkbox 
besides Adrenaline Numbers & Charts (non-English systems). You should also select the 
QuickStart Tutorial package as well as Sample files. Click on the Install button. Once the 
installation is complete, refer to the Read Me file located in the newly created folder labelled 
"Install Numbers & Charts" for instructions on manually installing Numbers & Charts.

General and OpenDoc issues

Memory requirements
Adrenaline Numbers & Charts requires at least 16 MB of physical RAM to run. However, we 
recommend that you either have more than 16 MB physical RAM, or that you have virtual 
memory activated to 24 MB or more, or that you use a product like Connectix's Ram Doubler
to better use your existing RAM. This will allow you to fully access all of Numbers & Charts' 
capabilities as well as allow you to extend your projects with other OpenDoc-based software.

Memory and Clipboard problems
Some problems may happen when opening stationery or documents from the Finder while 
the clipboard contains large amounts of data (such as a large selection of cells or a textured 
3DMF for example). These problems are not related to any particular OpenDoc editor or 
document but rather to the default OpenDoc memory settings.

You may observe the following symptoms :
Symptom 1: An error telling you "OpenDoc could not load" occurs when you attempt to open
a new document or stationery from the Finder. 

Symptom 2: You are unable to paste data into a specific document while you have no 
problem pasting data into other documents.

There are many ways by which one can get rid of the problem, and one should be chosen 
based on kind of work done and occurrence of the problem. These solutions may be applied 
to all OpenDoc LiveObjects.

Solution 1: Increase OpenDoc application memory a little
-Open your "System Folder->Extensions->OpenDoc Libraries" folder and select the OpenDoc
icon. Select Get Info from the File menu. A new window will pop up. In the bottom right hand 
side of the window, set the preferred memory size to 384 kilobytes. Close the window to 
accept the changes.

The advantage of this solution is that you should no longer encounter errors of the type in 
symptom 1.

If you continue to have memory problems as in Symptom 2, repeat the steps in Solution 1 
but set preferred memory to 1024 kilobytes.

Solution 2: Reset the Clipboard.
You may reset the Clipboard, or flush it, by copying a small amount of data to the Clipboard. 



This will replace the larger amount of data that was already there. You should then be able 
to re-import a larger data set via the Clipboard.

Printing problems
You may experience some printing errors with Adrenaline Numbers & Charts 1.0.2 when 
using the LaserWriter 8.4 or 8.4.1 driver. This problem is not unique to Adrenaline Numbers 
& Charts, and affects most OpenDoc-based software. Upgrading to LaserWriter 8.4.2 and 
OpenDoc 1.2 seems to correct the problem.

You may also experience printing problems when trying to print documents with the 
following parts embedded :
-C-Graph 1.1 Demo version
-WAV 1.0.1 (the latest version is 1.0.2)
-CalculatorPart 1.0
-Test Container 1.0
-Test Reniatnoc 1.0

Undo problems
Adrenaline Numbers and Adrenaline Charts are each open separately in container mode. In 
Adrenaline Charts, undo an action by selecting Undo from the Edit menu. Switch to 
Adrenaline Numbers and select Undo from the Edit menu. Charts will now become active but
its palettes will no longer appear. This is a known bug in OpenDoc and occurs with other 
known OpenDoc-based software.

Embedding issues
Embedding Numbers or Charts in other parts/containers many levels down.
Some problems may occur when you embed Adrenaline Numbers or Adrenaline Charts many
levels down in a document. These include Drag & Drop, copy data and more. We recommend
that you save often.

Problem with documents saved as Stationery
If Adrenaline Numbers & Charts is embedded in a document, along with a link to another 
OpenDoc part, that is then saved as a Stationery, the document is no longer readable. 
OpenDoc will return an error while attempting to open the document. This problem occurs 
when trying to create stationery with other OpenDoc products too, and is considered a bug 
in OpenDoc. Apple Computer is aware of the problem.

The workaround is to change the file from a stationery back into a regular document. In the 
Finder, select the icon of the document so that it is darkened. Now select the "Get info" 
command from the File menu of the Finder. This will bring up a new window. At the bottom 
right hand side of the window, uncheck the checkbox beside the words "Stationery Pad".

Scripting problems
You may have problems scripting if there are folders present in the Editors folder within the 
System folder. This is a known bug in OpenDoc 1.1. The trick is to take individual parts out of
sub-folders in the Editors folder, and bring them to the root level within the Editors folder.

Document sizes
It has been found that, in most cases, a document's size doesn't actually shrink by saving it 
multiple times to the disk. The file size can actually increase even though the document 
doesn't contain more data. The easy solution for shrinking the size of a document is to open 
it, save it under another name, then reopen the new copy.



Cancelling operations
Some operations in Numbers & Charts cannot be cancelled once begun. These include : 
importing text, changing a chart type, importing of Excel files, exporting as PICT files, etc. In 
a future release of Adrenaline Numbers & Charts, we will add a progress bar or the option to 
cancel.

Undoing operations
Some operations such as importing data, distribution, adding tables or matrices may 
overwrite existing data, and are not undo-able. This will addressed in a future release of 
Adrenaline Numbers & Charts.

Adrenaline Numbers issues

Printing Charts within Numbers
When Adrenaline Charts is embedded in Adrenaline Numbers and is the active part, you 
aren't able to print. To print, make Adrenaline Numbers the active part.

ScriptRunner incompatible with Numbers
ScriptRunner 1.1v2 is incompatible with Adrenaline Numbers. The next version of 
ScriptRunner should fix the problem.

Importing Excel 5.0 macros
Excel macros are converted into AppleScript scripts. When you import an Excel 5.0 macro 
sheet, only the first column is imported. Also, some Excel functions can not be translated. A 
good understanding of Excel macros and AppleScript is recommended. We also recommend 
you refer to the User's Manual for more in-depth information.

Using SYLK files
Adrenaline Numbers can import data and export it in the SYLK format. However, you may 
encounter some problems if you try to import into Adrenaline Numbers a SYLK file that was 
previously created with Adrenaline Numbers. Certain options (show/hide grid, show/hide 
scroll bars, show/hide headers) may not work, as well as certain functions. This will be 
addressed in a future release of Adrenaline Charts.

Using Cyberdog Picture Viewer with Numbers
When a picture is embedded in a Numbers worksheet using Cyberdog Picture Viewer, some 
screen refresh problem may appear when scrolling.    You may use Apple Image Viewer (in 
the OpenDoc Essentials Kit) to bypass this problem.

Adrenaline Charts issues

Applying 3DMF files to objects in a Chart
When you want to import a 3DMF file into Adrenaline Charts and apply it to more than one 
chart object, you can save memory by applying the 3DMF file to many objects at once, 
instead of one at a time. This possibility only applies to a contiguous ROW or COLUMN of 
objects, not non-contiguous selections*. However, you must be careful** in the way that you 
do it. First click on the 3DMF file in the Finder, drag it to the Adrenaline Charts' window THEN
hold down the option key. This will allows you to paste a 3DMF file onto a column (as defined
in your spreadsheet data).



Holding down the control key will allow you to paste a single 3DMF file onto a row of objects 
(as defined in your spreadsheet data).

Holding down BOTH the Option key and the Control key at the same time will allow you to 
apply a single 3DMF file to all of the objects (columns) in a chart.

* Note : You may not apply 3DMF objects to a non-contiguous selection via drag-and-drop. 
However, you may do so by first selecting the columns you wish to replace with 3D objects 
by Shift-clicking on them, then selecting Import from the "Chart" menu in Adrenaline Charts, 
or by pasting the 3DMF form the Clipboard.

** Note : On the Macintosh, if you are in an application and hold down the option key and 
click on the desktop, this has the effect of hiding the foreground application (the one you 
are/were in) in the background. That's why it's important to click on the object you need 
before holding down the option key, or any of the other command keys mentioned in this 
section.

Selecting all does not select the background
Using the Select All command (CMD+A) does not select the background. This is not a bug 
and should be considered the correct behavior considering the situation. This allows you to 
do a copy/cut and paste to export a 3DMF via the Clipboard.

Textures applied to 3DMF files
Due to a bug in QuickDraw 3D 1.5, a texture applied to one 3DMF object in a chart may 
overflow onto other columns/objects in the same chart. This bug is corrected in QuickDraw 
3D 1.5.1.

QuickTime and No Data
If you open a document containing QuickTime movies, you will receive a "No data" error if 
the QuickTime movies are not in their original folders when the document is re-opened. This 
will be fixed in a future release of Numbers & Charts.

Exporting and printing transparency
Due to a bug in QuickDraw 3D 1.5, it is not possible to export transparency when printing or 
saving as a PICT file via the "Export' command in the Chart menu. This will be fixed when 
QuickDraw 3D will be updated.

Labels and bitmap fonts
Some flat labels may be cutoff if you are using an italicized version (via the Style command 
in the font menu) of a bitmap font (ie : Times 9, Times 12). This does not occur with TrueType
fonts or Type 1 (PostScript) fonts. This will be fixed in a future release of Numbers & Charts.

Problems with drafts
When you close a draft in Adrenaline Charts, the palettes are automatically out away. To 
make them reappear, go to the Display menu, and choose the palettes you want to make 
reappear. This will be fixed in a future release of Adrenaline Charts.

The Format menu
When two parts are active in Adrenaline Charts at the same time, the format menu will only 
work in one part. To remedy this, make the font palette appear by selecting "Show Font 
palette" in the Display menu. This will be fixed in a future release of Adrenaline Charts.



Printing issues
Printing charts created in Adrenaline Charts can sometimes be long. This is a function of the 
onscreen size, and not the compexity of the chart. This will be fixed in a future release of 
Adrenaline Charts.

QuickDraw 3D issues

QuickDraw 3D hardware acceleration
Charts 1.0.2 now supports hardware acceleration from non-Apple hardware cards.

QuickDraw 3D plug-in renderers
Charts 1.0.2 now supports QuickDraw 3D plug-in renderers.    You may experience some 
problems when using Charts 1.0.2 with LightWork SuperLite 1.1 and LightWork HiddenLine 
1.1.      Flat text such as title, legend and labels won't appear in the rendered picture.    
Distorsion will also appear during printing.    To bypass this problem, we recommend that you
export your chart in PICT or JPEG format and then use another application to print.    This 
problem will be addressed in a maintenance upgrade to be announced by Lightwork 
(http://www.lightwork.com).

Getting updates

News of updates to Adrenaline Numbers & Charts will be made available at the Adrenaline 
Software web site at http://www.adrenaline.ca/.

If you register your software with your e-mail address included, you will be notified 
automatically of any updates.

Reporting bugs

While we hope we have crunched all known bugs in Adrenaline Numbers & Charts (aside 
from those mentioned here), we know that there can be others out there. We ask that you 
please send us your bugs either via e-mail at bugs@adrenaline.ca or via a handy form at our
Web site at http://www.adrenaline.ca/www/bugs.html

Purchasing Numbers & Charts 1.0.2

Adrenaline Numbers & Charts is available now through MacWarehouse in the USA and 
Canada, and Cyberian Outpost (http://www.cybout.com/). A special electronic-only version is 
available from C/Net’s BuyDirect.com (http://buydirect.com). The Suggested Retail Price of 
Adrenaline Numbers & Charts 1.0 is US$149.95, with an expected street price of US$99.

Cyberian Outpost      (1-800-856-9800) (Web : http://www.cybout.com/)
MacWarehouse USA      (1-800-397-8508) 
MacWarehouse Canada      (1-800-268-7805)
C/NET (electronic version) (Web : http://buydirect.com) (80$ and no taxes)

Technical support



Adrenaline Software does not offer technical support on demonstration versions of Numbers 
& Charts.

News about Adrenaline Numbers & Charts will be posted at the Adrenaline Software web 
site. 

Customer feedback

We thank you for trying Adrenaline Numbers & Charts 1.0.2. If you have any suggestions for 
improvements, please let us know. You may mail us your comments at 
comments@adrenaline.ca.

Adrenaline Software
May 23, 1997

Version D.


